User talk:Orwell

From LinuxWorks Minetest Server Wiki
Jump to navigation Jump to search

Weird Train Movements

Reading the trainlogic code (advtrains/trainlogic.lua:466), I noticed a minor bug that caused weird train behaviors. It should be train.acceleration=vdiff/dtime. I know that the part of the code may be replaced with the Hemiptera.png#137 fix, but the branch is still unstable. --Ywang (talk) 21:15, 8 December 2019 (CET)

Right. But so far, train.acceleration is only used for wagon entities to set their acceleration and not for actual movement, so this issue is not that pressing. It is sufficient IMO to fix this together with your changes.

--Orwell (talk) 10:05, 9 December 2019 (CET)

Schwarzschild Works

Red: Won't work, passenger platform
Cyan: Would work
Green: Old route

I'd like to know what you plan to do to preserve my access to East-West Link, a privately owned line, which previously ran past the east of the station but has now been removed at both sides (see green line on image). The track pair you have run into the ground beneath the river will not be appropriate as it ends up onto the surface platforms which carry passenger traffic - unless you mean for freight to run through track '5' (see cyan line on image). You have also built what looks like some new depot roads east of the subway depot over the space previously used as part of my line and I don't know what their purpose is.

--Blockhead (talk) 04:35, 22 December 2019 (CET)

I completed the construction yesterday in the evening. Indeed, Track 5 is primarily designated for your EWL traffic, however it is also possible now to switch lines and possibly also offer passenger services on the EWL (should this ever be taken into consideration).

I've set up default routes through the station so you can easily send trains along as before.

--Orwell (talk) 10:04, 24 December 2019 (CET)